Looxcie LX1 Wearable Bluetooth Camcorder, Android and iPhone Compatible

By on December 6th, 2010 in General

Looxcie requires an iPhone 3GS, iPhone 4, iPad, or iPod touch (4th generation) running iOS version 4.2 or higher, or an approved Android phone running Android version 2.0 or higher. If you don't see your device on the below list, please continue to check back as we're continually adding to the list.

Wow! Think is one cool device. Hi-tech design.